Office 365 Connectivity

Incident Report for NDYNAMICS

Resolved

Incident resolved.
Posted Oct 09, 2025 - 12:23 PDT

Monitoring

The incident is being remedied by Microsoft but performance is still degraded. We continue to monitor this issue.
Posted Oct 09, 2025 - 11:44 PDT

Identified

A Microsoft 365 status announcement on X states they are “investigating an issue with accessing Office.com” under incident ID MO1138499. This is only impacting users that use certain Internet Service Providers, with AT&T being one of the confirmed ISP's that are impacted. We've confirmed that customers on Comcast are not affected at this time.
Posted Oct 09, 2025 - 11:34 PDT

Update

The issue appears to only be impacting customers with specific internet service providers. We have confirmed that if you use ATT as a service provider that your Office 365 connectivity may be impacting your ability to send and receive email and use online Office applications. We are continuing to investigate.
Posted Oct 09, 2025 - 11:26 PDT

Investigating

We are currently investigating this issue.
Posted Oct 09, 2025 - 11:21 PDT
This incident affected: Microsoft Office 365.